File matrix-synapse-cryptography-version.patch of Package matrix-synapse

From 5ac36181ffd762d80f34c6d8b7a8bdd57a6a1598 Mon Sep 17 00:00:00 2001
From: Oleg Girko <ol@infoserver.lv>
Date: Tue, 6 Apr 2021 23:39:20 +0100
Subject: [PATCH] Don't require specific version of cryptography library.

This partially reverts 12d6184713 that was supposer to fix OpenSSL bug
by requiring cryptography Python package that is built with newer
OpenSSL library.

The problem with this approach is that Linux distributions (like Fedora)
ship this package built with OpenSSL dynamically linked and update
OpenSSL independently.

Requiring newest cryptography package is not just unnecessary, but also
doesn't work for these distributions because they have older version of
cryptography library.

Signed-off-by: Oleg Girko <ol@infoserver.lv>
---
 synapse/python_dependencies.py | 3 ---
 1 file changed, 3 deletions(-)

diff --git a/synapse/python_dependencies.py b/synapse/python_dependencies.py
index d844fbb3b..75290aca6 100644
--- a/synapse/python_dependencies.py
+++ b/synapse/python_dependencies.py
@@ -84,9 +84,6 @@ REQUIREMENTS = [
     "Jinja2>=2.9",
     "bleach>=1.4.3",
     "typing-extensions>=3.7.4",
-    # We enforce that we have a `cryptography` version that bundles an `openssl`
-    # with the latest security patches.
-    "cryptography>=3.4.7",
     "ijson>=3.1",
     "matrix-common==1.0.0",
 ]
-- 
2.34.1