File obs-server-2.10-0114-Dont-use-puma-server-default-version-from-rails-5-an.patch of Package obs-server

From bd100c55c5f43ac9e2794a1bf3708b583f753af2 Mon Sep 17 00:00:00 2001
From: Lukas Krause <lkrause@suse.de>
Date: Fri, 27 Mar 2020 12:15:09 +0100
Subject: [PATCH] Dont use puma server default version from rails 5 anymore

There is no reason to use the default puma version from
rails 5 after the migration to rails 6.0.

Co-authored-by: Eduardo Navarro <enavarro@suse.com>
---
 src/api/Gemfile      | 4 ++--
 src/api/Gemfile.lock | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/api/Gemfile b/src/api/Gemfile
index 06b60a9f11..0c0657ad35 100644
--- a/src/api/Gemfile
+++ b/src/api/Gemfile
@@ -181,8 +181,8 @@ group :development, :test do
   gem 'single_test'
   # to find n+1 queries
   gem 'bullet'
-  # Use Puma as the app server (rails 5 default)
-  gem 'puma', '~> 4.0'
+  # Use Puma as the app server
+  gem 'puma'
   # to drive headless chrome
   gem 'selenium-webdriver'
   # scan for security vulnerability (circleci only, do not touch)
diff --git a/src/api/Gemfile.lock b/src/api/Gemfile.lock
index 47083acc54..ed49d8cf93 100644
--- a/src/api/Gemfile.lock
+++ b/src/api/Gemfile.lock
@@ -545,7 +545,7 @@ DEPENDENCIES
   peek-mysql2
   pry (>= 0.9.12)
   pry-byebug
-  puma (~> 4.0)
+  puma
   pundit
   rails (~> 6.0)
   rails-assets-airbrake-js-client!
-- 
2.31.1