File obs-server-2.10-0003-api-Require-json-gem-explicitly-for-tests.patch of Package obs-server

From 25b837f4573d100b7a155be8ace78f7003fdcf73 Mon Sep 17 00:00:00 2001
From: Oleg Girko <ol@infoserver.lv>
Date: Sun, 13 Jul 2014 15:03:56 +0100
Subject: [PATCH] [api] Require json gem explicitly for tests.

The json gem is required by tests, but it was not listed in Gemfile,
relying on including it as a dependency for some other gem.
Unfortunately this assumption may be not true with some gem versions,
expecially when they are installed by system package manager,
without bundler.

Signed-off-by: Oleg Girko <ol@infoserver.lv>
---
 src/api/Gemfile      | 2 ++
 src/api/Gemfile.lock | 1 +
 2 files changed, 3 insertions(+)

diff --git a/src/api/Gemfile b/src/api/Gemfile
index 5b38df49d8..81b037ba12 100644
--- a/src/api/Gemfile
+++ b/src/api/Gemfile
@@ -143,6 +143,8 @@ group :test do
   gem 'rspec_junit_formatter'
   # to test rabbitmq support
   gem 'bunny-mock'
+  # for tests
+  gem 'json'
 end
 
 group :development, :test do
diff --git a/src/api/Gemfile.lock b/src/api/Gemfile.lock
index 8a3d27a2f4..9c0ba9a897 100644
--- a/src/api/Gemfile.lock
+++ b/src/api/Gemfile.lock
@@ -523,6 +523,7 @@ DEPENDENCIES
   jquery-datatables
   jquery-rails
   jquery-ui-rails (~> 4.2.1)
+  json
   kaminari
   launchy
   lograge
-- 
2.31.1