File obs-server-2.10-0023-frontend-Require-minimal-version-of-sanitize-webmock.patch of Package obs-server

From e016ddb880142fbc919a4e367d60371074fad1bc Mon Sep 17 00:00:00 2001
From: Oleg Girko <ol@infoserver.lv>
Date: Mon, 15 Oct 2018 00:19:07 +0100
Subject: [PATCH] [frontend] Require minimal version of sanitize, webmock, vcr
 gems.

Fedora build uses Gemfile and ignores Gemfile.lock
to generate dependencies, so requiring minimal versions
is important there.

Signed-off-by: Oleg Girko <ol@infoserver.lv>
---
 src/api/Gemfile      | 6 +++---
 src/api/Gemfile.lock | 6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/src/api/Gemfile b/src/api/Gemfile
index 58d9132d4a..63735d7b07 100644
--- a/src/api/Gemfile
+++ b/src/api/Gemfile
@@ -36,7 +36,7 @@ gem 'xmlhash', '>=1.3.6'
 # to escape HTML (FIXME: do we still use this?)
 gem 'escape_utils'
 # to sanitize HTML/CSS
-gem 'sanitize'
+gem 'sanitize', '>=4.1.0'
 # as authorization system
 gem 'pundit'
 # for password hashing
@@ -130,7 +130,7 @@ group :test do
   # to freeze time
   gem 'timecop'
   # to fake backend replies
-  gem 'webmock', '>= 2.3.0'
+  gem 'webmock', '>= 3.3.0'
   # for mocking and stubbing
   gem 'mocha', '> 0.13.0', require: false
   # for testing common Rails functionality with simple one-liners
@@ -156,7 +156,7 @@ group :development, :test do
   # for fixtures
   gem 'factory_bot_rails'
   # for mocking the backend
-  gem 'vcr'
+  gem 'vcr', '>= 4.0.0'
   # as alternative to the standard IRB shell
   gem 'pry', '>= 0.9.12'
   # add step-by-step debugging and stack navigation capabilities to pry
diff --git a/src/api/Gemfile.lock b/src/api/Gemfile.lock
index 62e1f83139..aaf54f287a 100644
--- a/src/api/Gemfile.lock
+++ b/src/api/Gemfile.lock
@@ -561,7 +561,7 @@ DEPENDENCIES
   rubocop-rails
   rubocop-rspec
   ruby-ldap
-  sanitize
+  sanitize (>=4.1.0)
   sassc-rails
   selenium-webdriver
   shoulda-matchers (~> 4.0)
@@ -573,9 +573,9 @@ DEPENDENCIES
   tilt (>= 1.4.1)
   timecop
   uglifier (>= 1.2.2)
-  vcr
+  vcr (>= 4.0.0)
   voight_kampff
-  webmock (>= 2.3.0)
+  webmock (>= 3.3.0)
   xmlhash (>= 1.3.6)
   xmlrpc
   yajl-ruby
-- 
2.31.1