File obs-server-2.10-0033-ci-Remove-capybara_minitest_spec-Ruby-gem.patch of Package obs-server

From 6387d77c5c37a13db8b1cf1f0a9e7dad480baa4e Mon Sep 17 00:00:00 2001
From: Oleg Girko <ol@infoserver.lv>
Date: Fri, 18 Jun 2021 17:34:01 +0100
Subject: [PATCH] [ci] Remove capybara_minitest_spec Ruby gem.

The capybara_minitest_spec Ruby gem is deprecated because
capybara supports minitest out of box starting from version 2.13.0.

Signed-off-by: Oleg Girko <ol@infoserver.lv>
---
 src/api/Gemfile             | 4 +---
 src/api/Gemfile.lock        | 4 ----
 src/api/test/test_helper.rb | 1 +
 3 files changed, 2 insertions(+), 7 deletions(-)

diff --git a/src/api/Gemfile b/src/api/Gemfile
index 63735d7b07..8425cb0ce9 100644
--- a/src/api/Gemfile
+++ b/src/api/Gemfile
@@ -124,9 +124,7 @@ group :test do
   # for spec like reporting
   gem 'minitest-reporters'
   # for integration testing
-  gem 'capybara'
-  # for rspec like matchers
-  gem 'capybara_minitest_spec'
+  gem 'capybara', '>= 2.13.0'
   # to freeze time
   gem 'timecop'
   # to fake backend replies
diff --git a/src/api/Gemfile.lock b/src/api/Gemfile.lock
index aaf54f287a..64a6a77604 100644
--- a/src/api/Gemfile.lock
+++ b/src/api/Gemfile.lock
@@ -86,9 +86,6 @@ GEM
       rack-test (>= 0.6.3)
       regexp_parser (~> 1.5)
       xpath (~> 3.2)
-    capybara_minitest_spec (1.0.7)
-      capybara (>= 2)
-      minitest (>= 4)
     childprocess (3.0.0)
     chunky_png (1.3.11)
     clockwork (2.0.3)
@@ -493,7 +490,6 @@ DEPENDENCIES
   bunny
   bunny-mock
   capybara
-  capybara_minitest_spec
   chunky_png
   clockwork (>= 0.7)
   cocoon
diff --git a/src/api/test/test_helper.rb b/src/api/test/test_helper.rb
index 522d878cac..b1220b4196 100644
--- a/src/api/test/test_helper.rb
+++ b/src/api/test/test_helper.rb
@@ -32,6 +32,7 @@ require_relative 'test_consistency_helper'
 require 'rails/test_help'
 
 require 'minitest/unit'
+require 'minitest/spec'
 
 require 'webmock/minitest'
 
-- 
2.31.1