File obs-server-2.10-0034-api-Add-explicit-sprockets-dependency.patch of Package obs-server

From 6e14f153bdf851db0025e9733954d9378d4837f1 Mon Sep 17 00:00:00 2001
From: Oleg Girko <ol@infoserver.lv>
Date: Sat, 26 Jun 2021 17:44:31 +0100
Subject: [PATCH] [api] Add explicit sprockets dependency.

This is needed to limit its version range because the way assets are
compiled is not compatible with sprockets 4.

Signed-off-by: Oleg Girko <ol@infoserver.lv>
---
 src/api/Gemfile      | 2 ++
 src/api/Gemfile.lock | 1 +
 2 files changed, 3 insertions(+)

diff --git a/src/api/Gemfile b/src/api/Gemfile
index 8425cb0ce9..3078063276 100644
--- a/src/api/Gemfile
+++ b/src/api/Gemfile
@@ -86,6 +86,8 @@ gem 'deep_cloneable', '~> 2.4.0'
 gem 'ajax-datatables-rails'
 # for mime lookup
 gem 'mini_mime', '>= 1.0.0'
+# assets compiling is not compatible with sprockets 4
+gem 'sprockets', '~> 3.0'
 
 group :development, :production do
   # to have the delayed job daemon
diff --git a/src/api/Gemfile.lock b/src/api/Gemfile.lock
index 64a6a77604..60bda06b05 100644
--- a/src/api/Gemfile.lock
+++ b/src/api/Gemfile.lock
@@ -564,6 +564,7 @@ DEPENDENCIES
   simplecov
   single_test
   sprite-factory (>= 1.5.2)
+  sprockets (~> 3.0)
   test-unit
   thinking-sphinx (> 3.1)
   tilt (>= 1.4.1)
-- 
2.31.1