File matrix-synapse-cryptography-version.patch of Package matrix-synapse

From f89e22e6c02642b981ea6a1f2585a111f96b9465 Mon Sep 17 00:00:00 2001
From: Oleg Girko <ol@infoserver.lv>
Date: Tue, 6 Apr 2021 23:39:20 +0100
Subject: [PATCH] Don't require specific version of cryptography library.

This partially reverts 12d6184713 that was supposed to fix OpenSSL bug
by requiring cryptography Python package that is built with newer
OpenSSL library.

The problem with this approach is that Linux distributions (like Fedora)
ship this package built with OpenSSL dynamically linked and update
OpenSSL independently.

Requiring newest cryptography package is not just unnecessary, but also
doesn't work for these distributions because they have older version of
cryptography library.

Signed-off-by: Oleg Girko <ol@infoserver.lv>
---
 pyproject.toml | 3 ---
 1 file changed, 3 deletions(-)

diff --git a/pyproject.toml b/pyproject.toml
index 1485016a5a..dfd6050294 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -202,9 +202,6 @@ Jinja2 = ">=3.0"
 bleach = ">=1.4.3"
 # We use `Self`, which were added in `typing-extensions` 4.0.
 typing-extensions = ">=4.0"
-# We enforce that we have a `cryptography` version that bundles an `openssl`
-# with the latest security patches.
-cryptography = ">=3.4.7"
 # ijson 3.1.4 fixes a bug with "." in property names
 ijson = ">=3.1.4"
 matrix-common = "^1.3.0"
-- 
2.45.2