File build-compare.spec of Package build-compare

#
# spec file for package build-compare
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via https://bugs.opensuse.org/
#

%define author openSUSE
%define git_ref 82ffb2760ae995c7fadbbee73d17b4e245f09b07
%define git_short_ref %(c=%{git_ref}; echo ${c:0:7})

Name:           build-compare
Version:        2023.04.28.git.%{git_short_ref}
Release:        0
Summary:        Build Result Compare Script
License:        GPL-2.0-or-later
Group:          Development/Tools/Building
URL:            https://github.com/openSUSE/build-compare
Source0:        https://github.com/%{author}/%{name}/archive/%{git_ref}/%{name}-%{git_ref}.tar.gz
BuildRoot:      %{_tmppath}/%{name}-%{version}-build
#!BuildIgnore:  build-compare
BuildArch:      noarch
%if 0%{?suse_version}
Requires:       bash
Requires:       coreutils
Requires:       cpio
Requires:       diffutils
Requires:       file
Requires:       gawk
Requires:       grep
Requires:       rpm
Requires:       sed
%endif

%description
This package contains scripts to find out if the build result differs
to a former build.

%prep
mkdir $RPM_BUILD_DIR/%name-%version
%setup -n %{name}-%{git_ref}

%build

%install
mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/build/
install -m 0755 \
        same-build-result.sh pkg-diff.sh functions.sh srpm-check.sh \
        $RPM_BUILD_ROOT%{_prefix}/lib/build/

%files
%if 0%{?suse_version} < 1500
%defattr(-,root,root)
%doc COPYING
%else
%license COPYING
%endif
%{_prefix}/lib/build

%changelog