File rust-inquire.spec of Package rust-inquire
# Generated by rust2rpm 26
%bcond_with check
%global debug_package %{nil}
%global crate inquire
Name: rust-%{crate}
Version: 0.7.5
Release: 1%{?dist}
Summary: Library for building interactive prompts on terminals
License: MIT
URL: https://crates.io/crates/inquire
Source: https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Inquire is a library for building interactive prompts on terminals.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
# FIXME: no license files detected
%doc %{crate_instdir}/CRATE_README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+chrono-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+chrono-devel %{_description}
This package contains library source intended for building other packages which
use the "chrono" feature of the "%{crate}" crate.
%files -n %{name}+chrono-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+console-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+console-devel %{_description}
This package contains library source intended for building other packages which
use the "console" feature of the "%{crate}" crate.
%files -n %{name}+console-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+crossterm-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+crossterm-devel %{_description}
This package contains library source intended for building other packages which
use the "crossterm" feature of the "%{crate}" crate.
%files -n %{name}+crossterm-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+date-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+date-devel %{_description}
This package contains library source intended for building other packages which
use the "date" feature of the "%{crate}" crate.
%files -n %{name}+date-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+editor-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+editor-devel %{_description}
This package contains library source intended for building other packages which
use the "editor" feature of the "%{crate}" crate.
%files -n %{name}+editor-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fuzzy-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fuzzy-devel %{_description}
This package contains library source intended for building other packages which
use the "fuzzy" feature of the "%{crate}" crate.
%files -n %{name}+fuzzy-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+fuzzy-matcher-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+fuzzy-matcher-devel %{_description}
This package contains library source intended for building other packages which
use the "fuzzy-matcher" feature of the "%{crate}" crate.
%files -n %{name}+fuzzy-matcher-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+macros-devel %{_description}
This package contains library source intended for building other packages which
use the "macros" feature of the "%{crate}" crate.
%files -n %{name}+macros-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+one-liners-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+one-liners-devel %{_description}
This package contains library source intended for building other packages which
use the "one-liners" feature of the "%{crate}" crate.
%files -n %{name}+one-liners-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+tempfile-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+tempfile-devel %{_description}
This package contains library source intended for building other packages which
use the "tempfile" feature of the "%{crate}" crate.
%files -n %{name}+tempfile-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+termion-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+termion-devel %{_description}
This package contains library source intended for building other packages which
use the "termion" feature of the "%{crate}" crate.
%files -n %{name}+termion-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif