File rust-iroh-metrics.spec of Package rust-iroh-metrics

# Generated by rust2rpm 26
%bcond_with check
%global debug_package %{nil}

%global crate iroh-metrics

Name:           rust-%{crate}
Version:        0.18.0
Release:        1%{?dist}
Summary:        Metrics for iroh

License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/iroh-metrics
Source:         https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Metrics for iroh.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
# FIXME: no license files detected
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+metrics-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+metrics-devel %{_description}

This package contains library source intended for building other packages which
use the "metrics" feature of the "%{crate}" crate.

%files       -n %{name}+metrics-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+prometheus-client-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+prometheus-client-devel %{_description}

This package contains library source intended for building other packages which
use the "prometheus-client" feature of the "%{crate}" crate.

%files       -n %{name}+prometheus-client-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif