File rust-iroh-sync.spec of Package rust-iroh-sync

# Generated by rust2rpm 26
%bcond_with check
%global debug_package %{nil}

%global crate iroh-sync

Name:           rust-%{crate}
Version:        0.14.0
Release:        1%{?dist}
Summary:        Iroh sync

# Upstream license specification: MIT/Apache-2.0
License:        MIT OR Apache-2.0
URL:            https://crates.io/crates/iroh-sync
Source:         https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
Iroh sync.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+futures-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+futures-devel %{_description}

This package contains library source intended for building other packages which
use the "futures" feature of the "%{crate}" crate.

%files       -n %{name}+futures-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+iroh-metrics-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+iroh-metrics-devel %{_description}

This package contains library source intended for building other packages which
use the "iroh-metrics" feature of the "%{crate}" crate.

%files       -n %{name}+iroh-metrics-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+iroh-net-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+iroh-net-devel %{_description}

This package contains library source intended for building other packages which
use the "iroh-net" feature of the "%{crate}" crate.

%files       -n %{name}+iroh-net-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+metrics-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+metrics-devel %{_description}

This package contains library source intended for building other packages which
use the "metrics" feature of the "%{crate}" crate.

%files       -n %{name}+metrics-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+net-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+net-devel %{_description}

This package contains library source intended for building other packages which
use the "net" feature of the "%{crate}" crate.

%files       -n %{name}+net-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+quinn-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+quinn-devel %{_description}

This package contains library source intended for building other packages which
use the "quinn" feature of the "%{crate}" crate.

%files       -n %{name}+quinn-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+tokio-stream-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-stream-devel %{_description}

This package contains library source intended for building other packages which
use the "tokio-stream" feature of the "%{crate}" crate.

%files       -n %{name}+tokio-stream-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+tokio-util-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+tokio-util-devel %{_description}

This package contains library source intended for building other packages which
use the "tokio-util" feature of the "%{crate}" crate.

%files       -n %{name}+tokio-util-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif