File rust-numtoa-0.1.spec of Package rust-numtoa-0.1
# Generated by rust2rpm 26
%bcond_with check
%global debug_package %{nil}
%global crate numtoa
Name: rust-%{crate}-0.1
Version: 0.1.0
Release: 1%{?dist}
Summary: Convert numbers into stack-allocated byte arrays
License: MIT OR Apache-2.0
URL: https://crates.io/crates/numtoa
Source: https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Convert numbers into stack-allocated byte arrays.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif