File rust-quic-rpc.spec of Package rust-quic-rpc
# Generated by rust2rpm 26
%bcond_with check
%global debug_package %{nil}
%global crate quic-rpc
Name: rust-%{crate}
Version: 0.14.0
Release: 1%{?dist}
Summary: Streaming rpc system based on quic
# Upstream license specification: Apache-2.0/MIT
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/quic-rpc
Source: https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A streaming rpc system based on quic.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+combined-transport-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+combined-transport-devel %{_description}
This package contains library source intended for building other packages which
use the "combined-transport" feature of the "%{crate}" crate.
%files -n %{name}+combined-transport-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+flume-transport-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+flume-transport-devel %{_description}
This package contains library source intended for building other packages which
use the "flume-transport" feature of the "%{crate}" crate.
%files -n %{name}+flume-transport-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+futures-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+futures-devel %{_description}
This package contains library source intended for building other packages which
use the "futures" feature of the "%{crate}" crate.
%files -n %{name}+futures-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+hyper-transport-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+hyper-transport-devel %{_description}
This package contains library source intended for building other packages which
use the "hyper-transport" feature of the "%{crate}" crate.
%files -n %{name}+hyper-transport-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+macros-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+macros-devel %{_description}
This package contains library source intended for building other packages which
use the "macros" feature of the "%{crate}" crate.
%files -n %{name}+macros-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+quinn-transport-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+quinn-transport-devel %{_description}
This package contains library source intended for building other packages which
use the "quinn-transport" feature of the "%{crate}" crate.
%files -n %{name}+quinn-transport-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif