File rust-ring-0.16.spec of Package rust-ring-0.16
# Generated by rust2rpm 26
%bcond_with check
%global debug_package %{nil}
%global crate ring
Name: rust-%{crate}-0.16
Version: 0.16.20
Release: 1%{?dist}
Summary: Safe, fast, small crypto using Rust
License: None
# FIXME: No license information in crate metadata.
URL: https://crates.io/crates/ring
Source: https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate
# Automatically generated patch to strip dependencies and normalize metadata
Patch: ring-fix-metadata-auto.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Safe, fast, small crypto using Rust.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE
%license %{crate_instdir}/third_party/fiat/LICENSE
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+alloc-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+alloc-devel %{_description}
This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.
%files -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+dev_urandom_fallback-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+dev_urandom_fallback-devel %{_description}
This package contains library source intended for building other packages which
use the "dev_urandom_fallback" feature of the "%{crate}" crate.
%files -n %{name}+dev_urandom_fallback-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+internal_benches-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+internal_benches-devel %{_description}
This package contains library source intended for building other packages which
use the "internal_benches" feature of the "%{crate}" crate.
%files -n %{name}+internal_benches-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+once_cell-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+once_cell-devel %{_description}
This package contains library source intended for building other packages which
use the "once_cell" feature of the "%{crate}" crate.
%files -n %{name}+once_cell-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+slow_tests-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+slow_tests-devel %{_description}
This package contains library source intended for building other packages which
use the "slow_tests" feature of the "%{crate}" crate.
%files -n %{name}+slow_tests-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+std-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+std-devel %{_description}
This package contains library source intended for building other packages which
use the "std" feature of the "%{crate}" crate.
%files -n %{name}+std-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+test_logging-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+test_logging-devel %{_description}
This package contains library source intended for building other packages which
use the "test_logging" feature of the "%{crate}" crate.
%files -n %{name}+test_logging-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+wasm32_c-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+wasm32_c-devel %{_description}
This package contains library source intended for building other packages which
use the "wasm32_c" feature of the "%{crate}" crate.
%files -n %{name}+wasm32_c-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif