File rust-simplelog.spec of Package rust-simplelog
# Generated by rust2rpm 26
%bcond_without check
%global debug_package %{nil}
%global crate simplelog
Name: rust-%{crate}
Version: 0.12.2
Release: 1%{?dist}
Summary: Simple and easy-to-use logging facility for Rust's log crate
License: MIT OR Apache-2.0
URL: https://crates.io/crates/simplelog
Source: https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
A simple and easy-to-use logging facility for Rust's log crate.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE.APACHE2
%license %{crate_instdir}/LICENSE.MIT
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+ansi_term-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+ansi_term-devel %{_description}
This package contains library source intended for building other packages which
use the "ansi_term" feature of the "%{crate}" crate.
%files -n %{name}+ansi_term-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+local-offset-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+local-offset-devel %{_description}
This package contains library source intended for building other packages which
use the "local-offset" feature of the "%{crate}" crate.
%files -n %{name}+local-offset-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+paris-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+paris-devel %{_description}
This package contains library source intended for building other packages which
use the "paris" feature of the "%{crate}" crate.
%files -n %{name}+paris-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+termcolor-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+termcolor-devel %{_description}
This package contains library source intended for building other packages which
use the "termcolor" feature of the "%{crate}" crate.
%files -n %{name}+termcolor-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+test-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+test-devel %{_description}
This package contains library source intended for building other packages which
use the "test" feature of the "%{crate}" crate.
%files -n %{name}+test-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif