File rust-sqlite3-sys.spec of Package rust-sqlite3-sys
# Generated by rust2rpm 24
%bcond_without check
%global debug_package %{nil}
%global crate sqlite3-sys
Name: rust-%{crate}
Version: 0.14.0
Release: 1%{?dist}
Summary: Package provides bindings to SQLite
# Upstream license specification: Apache-2.0/MIT
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/sqlite3-sys
Source: https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate
BuildRequires: rust-packaging >= 21
%global _description %{expand:
The package provides bindings to SQLite.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+linkage-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+linkage-devel %{_description}
This package contains library source intended for building other packages which
use the "linkage" feature of the "%{crate}" crate.
%files -n %{name}+linkage-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+sqlite3-src-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+sqlite3-src-devel %{_description}
This package contains library source intended for building other packages which
use the "sqlite3-src" feature of the "%{crate}" crate.
%files -n %{name}+sqlite3-src-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires
%build
%cargo_build
%install
%cargo_install
%if %{with check}
%check
%cargo_test
%endif