File rust-thread-priority.spec of Package rust-thread-priority

# rust-thread-priority.spec
# Generated by rust2rpm 21
%bcond_with check
%global debug_package %{nil}

%global crate thread-priority

Name:           rust-%{crate}
Version:        0.9.2
Release:        1%{?dist}
Summary:        Library for managing threads priority and schedule policies

# Upstream license specification: MIT
License:        MIT
URL:            https://crates.io/crates/thread-priority
Source:         https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate
# Automatically generated patch to strip foreign dependencies
Patch:          thread-priority-fix-metadata-auto.diff

ExclusiveArch:  %{rust_arches}

BuildRequires:  rust-packaging >= 21

%global _description %{expand:
Library for managing threads priority and schedule policies.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version_no_tilde} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif