File rust-tokio-rustls-acme.spec of Package rust-tokio-rustls-acme
# Generated by rust2rpm 26
%bcond_with check
%global debug_package %{nil}
%global crate tokio-rustls-acme
Name: rust-%{crate}
Version: 0.4.0
Release: 1%{?dist}
Summary: Automatic TLS certificate management using rustls
License: Apache-2.0 OR MIT
URL: https://crates.io/crates/tokio-rustls-acme
Source: https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate
# Manually created patch for downstream crate metadata changes
Patch: tokio-rustls-acme-fix-metadata.diff
BuildRequires: cargo-rpm-macros >= 24
%global _description %{expand:
Automatic TLS certificate management using rustls.}
%description %{_description}
%package devel
Summary: %{summary}
BuildArch: noarch
%description devel %{_description}
This package contains library source intended for building other packages which
use the "%{crate}" crate.
%files devel
%license %{crate_instdir}/LICENSE-APACHE
%license %{crate_instdir}/LICENSE-MIT
%doc %{crate_instdir}/README.md
%{crate_instdir}/
%package -n %{name}+default-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+default-devel %{_description}
This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.
%files -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml
%package -n %{name}+axum-devel
Summary: %{summary}
BuildArch: noarch
%description -n %{name}+axum-devel %{_description}
This package contains library source intended for building other packages which
use the "axum" feature of the "%{crate}" crate.
%files -n %{name}+axum-devel
%ghost %{crate_instdir}/Cargo.toml
%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep
%generate_buildrequires
%cargo_generate_buildrequires -a
%build
%cargo_build -a
%install
%cargo_install -a
%if %{with check}
%check
%cargo_test -a
%endif