File rust-x25519-dalek.spec of Package rust-x25519-dalek

# Generated by rust2rpm 26
%bcond_with check
%global debug_package %{nil}

%global crate x25519-dalek

Name:           rust-%{crate}
Version:        2.0.1
Release:        1%{?dist}
Summary:        X25519 elliptic curve Diffie-Hellman key exchange in pure-Rust, using curve25519-dalek

License:        BSD-3-Clause
URL:            https://crates.io/crates/x25519-dalek
Source:         https://crates.io/api/v1/crates/%crate/%version/download#/%crate-%version.crate

BuildRequires:  cargo-rpm-macros >= 24

%global _description %{expand:
X25519 elliptic curve Diffie-Hellman key exchange in pure-Rust, using
curve25519-dalek.}

%description %{_description}

%package        devel
Summary:        %{summary}
BuildArch:      noarch

%description    devel %{_description}

This package contains library source intended for building other packages which
use the "%{crate}" crate.

%files          devel
%license %{crate_instdir}/LICENSE
%doc %{crate_instdir}/CHANGELOG.md
%doc %{crate_instdir}/README.md
%{crate_instdir}/

%package     -n %{name}+default-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+default-devel %{_description}

This package contains library source intended for building other packages which
use the "default" feature of the "%{crate}" crate.

%files       -n %{name}+default-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+alloc-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+alloc-devel %{_description}

This package contains library source intended for building other packages which
use the "alloc" feature of the "%{crate}" crate.

%files       -n %{name}+alloc-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+getrandom-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+getrandom-devel %{_description}

This package contains library source intended for building other packages which
use the "getrandom" feature of the "%{crate}" crate.

%files       -n %{name}+getrandom-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+precomputed-tables-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+precomputed-tables-devel %{_description}

This package contains library source intended for building other packages which
use the "precomputed-tables" feature of the "%{crate}" crate.

%files       -n %{name}+precomputed-tables-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+reusable_secrets-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+reusable_secrets-devel %{_description}

This package contains library source intended for building other packages which
use the "reusable_secrets" feature of the "%{crate}" crate.

%files       -n %{name}+reusable_secrets-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+serde-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+serde-devel %{_description}

This package contains library source intended for building other packages which
use the "serde" feature of the "%{crate}" crate.

%files       -n %{name}+serde-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+static_secrets-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+static_secrets-devel %{_description}

This package contains library source intended for building other packages which
use the "static_secrets" feature of the "%{crate}" crate.

%files       -n %{name}+static_secrets-devel
%ghost %{crate_instdir}/Cargo.toml

%package     -n %{name}+zeroize-devel
Summary:        %{summary}
BuildArch:      noarch

%description -n %{name}+zeroize-devel %{_description}

This package contains library source intended for building other packages which
use the "zeroize" feature of the "%{crate}" crate.

%files       -n %{name}+zeroize-devel
%ghost %{crate_instdir}/Cargo.toml

%prep
%autosetup -n %{crate}-%{version} -p1
%cargo_prep

%generate_buildrequires
%cargo_generate_buildrequires

%build
%cargo_build

%install
%cargo_install

%if %{with check}
%check
%cargo_test
%endif