File hovercraft.spec of Package hovercraft

Name:               hovercraft
Version:            2.7
Release:            1%{?dist}
Summary:            Makes impress.js presentations from reStructuredText

# Upstream does not include a COPYING file.
# https://github.com/regebro/hovercraft/issues/25
License:            CC0 and BSD
URL:                https://pypi.io/project/hovercraft
Source0:            https://github.com/regebro/%{name}/archive/%{version}/%{name}-%{version}.tar.gz
Patch0:             hovercraft-fix-tests.patch

BuildArch:          noarch

BuildRequires:      python3-devel
BuildRequires:      python3-setuptools
BuildRequires:      python3-docutils >= 0.9
BuildRequires:      python3-lxml >= 3.1.0
BuildRequires:      python3-svg-path
BuildRequires:      python3-pygments
BuildRequires:      python3-watchdog
BuildRequires:      impressjs

BuildRequires:      python3-sphinx

# Temporary.  Try removing.
BuildRequires:      python3-manuel

Requires:           python3
Requires:           python3-docutils >= 0.9
Requires:           python3-lxml >= 3.1.0
Requires:           python3-svg-path
Requires:           python3-pygments
Requires:           python3-watchdog
Requires:           impressjs


%description
The merge of convenience and cool!

Hovercraft is a tool to make impress.js presentations from
reStructuredText.

- Write your presentations in a text markup language. No slow, limiting
  GUI, no annoying HTML!
- Pan, rotate and zoom in 3D, with automatic repositioning of slides!
- A presenter console with notes and slide previews!
- The slide show generated is in HTML, so you only need a web browser to
  show it.
- Easy sharing, as it can be put up on a website for anyone to see!

%prep
%autosetup -n %{name}-%{version} -p1

# Remove bundled egg-info in case it exists
rm -rf %{name}.egg-info

%build
%{__python3} setup.py build

cd docs
make man
cd -

%install
%{__python3} setup.py install -O1 --skip-build --root=%{buildroot}

# Unbundle impress.js
rm %{buildroot}%{python3_sitelib}/hovercraft/templates/default/js/impress.js
rm %{buildroot}%{python3_sitelib}/hovercraft/templates/simple/js/impress.js
ln -s %{_datadir}/impressjs/impress.js \
    %{buildroot}%{python3_sitelib}/hovercraft/templates/default/js/impress.js
ln -s %{_datadir}/impressjs/impress.js \
    %{buildroot}%{python3_sitelib}/hovercraft/templates/simple/js/impress.js

%{__install} -d -m 755 %{buildroot}%{_mandir}/man1/
%{__install} -m 644 docs/build/man/hovercraft.1 %{buildroot}%{_mandir}/man1/

# Remove test data
rm -rf %{buildroot}%{python3_sitelib}/tests

%check
%{__python3} -m unittest

%files
%doc README.rst CHANGES.txt docs
%{_bindir}/%{name}
%{python3_sitelib}/%{name}/
%{python3_sitelib}/%{name}-%{version}*
%{_mandir}/man1/hovercraft.1*